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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to HFSS for beginners and advanced
users. It includes instructions to create, simulate, and analyze a dielectric resonator antenna.

What You Will Learn

By following the steps in this guide, you will learn how to perform the following HFSS tasks in
Ansys Electronics Desktop:

l Draw a geometric model
l Modify a model’s design parameters
l Assign variables to a model’s design parameters
l Specify solution settings for a design
l Validate a design’s setup
l Run an HFSS simulation
l Create a 2D X-Y plot of S-parameter results
l Create a field overlay plot of results
l Create a phase animation of results

Sample Project - Dielectric Resonator Antenna (DRA)
This antenna is cavity-backed with an annular-slot-fed hemispherical dielectric resonator. The
antenna feed is achieved by coaxial excitation across one side of an annular slot between the
cavity and the DRA dielectric. For this project, the engineering focus is on the behavior of the
antenna itself, not its feed. Therefore, the model will feed with a lumped port across an annular
slot. The design’s operating frequency is 3.5 GHz.

Note:

This project is also described and analyzed in the following IEEE publication:

l Leung, K.W., So, K.K., “Annular-slot-Excited Dielectric Resonator Antenna with
a Backing Cavity,” IEEE Transactions on Antennas and Propagation,
August 2002.

A half-symmetry model of a Dielectric Resonator Antenna (DRA), designed in Ansys Electronics
Desktop as an HFSS design, is illustrated in the following figure:

Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)
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Figure 1-1: Sample Project - Dielectric Resonator Antenna (DRA)

Finite Element Method
The geometry for the DRA described in this document appears in the following figure.

In HFSS, the model is automatically divided into a large number of tetrahedra. A tetrahedron is a
four-sided polyhedron with planar faces that are all triangular (also referred to as a triangular pyr-
amid). Unlike the pyramids of Egypt, the base is triangular, not rectangular, and there is one

Introduction 1-2
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fewer side. This collection of tetrahedra is referred to as the finite element mesh. The figure
below shows the automatically created mesh for the DRA.

Figure 1-2: The Mesh that Constitutes the Antenna

Dividing a structure into thousands of smaller, basic regions (elements) allows the system to
compute the field solution separately in each element. The computations at each individual ele-
ment are relatively simple, but together, the elements can represent a complex and otherwise
unsolvable structure. Generally, the smaller the systemmakes the elements, the more accurate
the final solution will be. The quality of the elements (aspect ratio, internal angles, and so on) is
also a consideration.

Overview of the Interface
This section provides an overview of the HFSS user interface. The following figure represents an
HFSS design of a dielectric resonator antenna within the Ansys Electronics Desktop.

Introduction 1-3
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Figure 1-3: Overview of the Ansys Electronics Desktop Graphical User Interface

The following table describes the different options present in the user interface:

1 Project Manager
Window

Displays details of the design projects. Each project has
its own main branch of the project tree, which ultimately
includes various information and options (like the type of
design, boundaries and excitations, analysis setups, and
analysis results).

Introduction 1-4
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2 ModelerWindow Includes the drawing area of the active model and the His-
tory Tree (item 3).

3 History Tree Displays all operations and commands carried out on the
active model (such as information about the model’s
objects, all actions associated with each object, and
coordinate system information).

4 Ribbon Contains various commands and options to create, man-
age, set up, analyze, and evaluate your designs and to
customize program options. These commands and
options are organized into related sets, with each logical
group on a separate tab. The ordering of the tabs is
designed to follow a left-to-right workflow. Certain popular
commands (such as Save and various View options)
appear on multiple tabs.

Not all of the available commands can be accessed via
the ribbon. Others are accessed from theMenu Bar (item
5) and shortcut menus that appear when you right-click.

5 Menu Bar Provides various menus that enable you to perform all of
the HFSS tasks (such as managing project files, cus-
tomizing the desktop components, drawing objects, and
setting and modifying all project parameters).

6 PropertiesWindow Displays the attributes of a selected object in the active
model (such as the object’s name, material assignment,
orientation, color, and transparency). This window also
displays information about a selected command that has
been carried out. For example, if a circle was drawn, the
information about the command includes its name
(CreateCircle), the type and name of the coordinate sys-
tem the circle was drawn in, the coordinates of the circle’s
center position, its axis, and its radius.

To differentiate this window from the similar Properties dia-
log box, it is typically referred to as the "docked Properties
window" within the Getting Started Guides.

Introduction 1-5
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7 Status Bar Shows current actions and provides instructions.

Also, depending on the command being carried out, the
status bar can display the X, Y, and Z coordinate boxes;
the Absolute/Relative drop-down menu to choose
whether to enter a point’s absolute or relative coordinates;
a drop-down menu to specify points in Cartesian,
Cylindrical, or Spherical coordinates; and the active
model’s unit setting.

8 Message Manager
Window

Displays errors, warnings, and informational messages
for an active project.

9 ProgressWindow Displays solution progress information.

10 Component Librar-
iesWindow

This window is one of several that you can optionally dis-
play or hide via the Viewmenu. It displays 3D com-
ponents that are stored in the SysLib and PersonalLib
directories. From here you can easily add 3D components
into your project.

Other windows you can display here contain Com-
ponents, Layers, and Nets information. Additionally, the
ACT Extensions window (supported onWindows plat-
forms only) has wizards to automate the creation of vari-
ous models.

11 Orientation Gadget This gadget is a graphical tool for quickly and easily manip-
ulating the view orientation.

Introduction 1-6
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2 - Create the New Project
This chapter contains the following topics:

l Launch the application and insert an HFSS design
l Enable legacy view orientations
l Set the units of measurement
l Verify HFSS and modeler options
l Select the solution type
l Set the coordinate system

Launch EDT and Insert an HFSS Design
Launch the Ansys Electronics Desktop appplication and insert an HFSS Design in which to cre-
ate the dielectric resonator antenna (DRA). There are several procedures to complete prior to
beginning model construction.

Launch Ansys Electronics Desktop (EDT):

For convenience, a shortcut to the EDT application is placed on your desktop during program
installation. Optionally, you may want to pin the shortcut to your Windows Start Menu too.

1. Double-click Ansys Electronics Desktop (or click the same shortcut on your
Start Menu) to launch the application.

Ansys Electronics Desktop opens.

Figure 2-1: Ansys EDT Application Launched

Create the New Project 2-1
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Note:

If a project is not listed at the top of the Project Manager, click New on the
Desktop ribbon tab to include one. If the Project Manager window does not
appear after launching the application, go to the Viewmenu and select the Pro-
ject Manager option.

Insert an HFSS Design:

2. On the Desktop ribbon tab, click Insert HFSS Design.

HFSSDesignx appears in the Project Manager. Click + to expand the branch.

Figure 2-2: HFSSDesignx Inserted

Create the New Project 2-2

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)

Note:

The Definitions folder includes materials, scripts, and other data stored under the
project name.

3. On the Desktop ribbon tab, click Save As.

The Save As dialog box appears.

4. Browse for a location to store the file (such as D:\MyProjects), and then double-click the
folder’s name. You can also create a new folder through this dialog box.

5. Type DRA in the File name text box and then click Save.

This operation saves the project in the specified location with the file extension aedt.
Notice that the project name at the top of the Project Manager has been updated too.

Enable Legacy View Orientations
This getting started guide was created based on standard view orientations that were in effect
for version 2023 R2 and earlier of the Ansys Electronics Desktop application. For consistency
between your experience and the views and instructions contained in this guide, select the
Enable Legacy View Orientation option in the 3D UI Options dialog box, as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Select Enable Legacy View Orientation:

Create the New Project 2-3
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3. ClickOK.

Changing the view orientation option does not change the model viewpoint that was in
effect at the time.

4. On the Draw ribbon tab, click Orient to change to the Trimetric view, which is the
default legacy view orientation.

You do not have to select Trimetric from theOrient drop-down menu. The default view
appears when you clickOrient.

Although this option can only be accessed once a design is added to a project, it is a global
option. Your choice is retained for all future program sessions, projects, and design types that
use the 3D Modeler or that produce 3D plots of results.

At the end of this guide, you will be prompted to clear the Enable Legacy View Orientation
option, if you prefer to use the view orientation scheme implemented for 2024 R1 and newer ver-
sions going forward.

For a comparison of the legacy and current view orientations, search for "View Options: 3D UI
Options" in the HFSS help. Additionally, views associated with Alt + double-click zones have

Create the New Project 2-4
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been redefined. The current orientations are shown in the help topic, "Changing the Model View
with Alt+Double-Click Areas."

Set the Units of Measurement
Set the units of measurement for drawing the geometric model to millimeters, as follows:

1. On Draw ribbon tab, click Units.

The Set Model Units and Max Extent dialog box appears.

2. Selectmm (millimeters) from the Select units drop-down menu if it is not already selec-
ted.

Keep the Rescale to new units and Advanced options cleared.

Figure 2-3: Set Model Units Dialog Box

3. ClickOK.

Verify HFSS and Modeler Options
Verify the relevant general options, as follows:

1. On the Desktop ribbon tab, click General Options.

TheOptions dialog box appears.

2. In the options tree, expand the HFSS branch and select Boundary Assignment.
3. Ensure all Boundary Assignment options are selected, as shown below:

Create the New Project 2-5
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Figure 2-4: Options Dialog Box – HFSS > Boundary Assignment Group

4. In the options tree, expand the 3D Modeler Options branch and select Drawing.
5. Ensure that the following two options are selected, as shown in the figure below:

l Automatically cover closed polylines
l Edit properties of new primitives

Note:

This option causes a Properties dialog box to appear when you create a
new primitive/object.

Create the New Project 2-6
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Figure 2-5: Options Dialog Box – 3D Modeler > Drawing Group

6. In the options tree, select 3D Modeler >Operation.
7. In the Clone section, select Clone tool objects before intersecting.

Figure 2-6: Options Dialog Box – 3D Modeler > Operation Group

Note:

This option instructs the 3D Modeler to always keep a copy of the first item selec-
ted when that object is intersected with one or more other objects.

8. ClickOK.

Grid Settings

The grid displayed in theModeler window is a drawing aid to visualize the location of objects and
to draw objects to prescribed size increments. The cursor snaps to grid point by default when
you click the mouse while drawing objects. The points on the grid are divided by their local x-, y-,
and z-coordinates, and grid spacing is set according to the current project’s drawing units.

For this antenna project, you do not need to edit any of the grid’s default properties.

Create the New Project 2-7
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Note:

To edit the grid properties, click the Viewmenu and selectGrid Settings. TheGrid
Spacing dialog box appears. Use this dialog box to control the grid type (Cartesian or
polar), style (dots or lines), density, spacing, or visibility.

Select the Solution Type
To set the solution type:

1. From the menu bar, click HFSS > Solution Type.

The Solution Type dialog box opens.

2. UnderOptions, selectModal and also ensure that the remaining settings are as shown in
the following image:

Figure 2-7: Solution Type Dialog Box

Create the New Project 2-8

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)

Note:

Since this antenna project is a mode-based problem,Modal is the appropriate
solution type option.

3. ClickOK.

At this point you can start drawing the antenna geometry.

Set the Coordinate System

For this antenna problem, use theGlobal coordinate system (CS) as the working CS. This
coordinate system is fixed and is active by default. You can create other coordinate systems to
facilitate orienting new objects. The available CS types are summarized in the table below:

Global CS The fixed, default CS for each new project.

Relative CS A user-defined CS. Its origin and orientation can be set relative to the global
CS, relative to another Relative CS, or relative to a geometric feature. This
type of CS enables you to easily draw objects that are located relative to
other objects.

Face CS A user-defined CS. Its origin is specified on a planar object face. This type of
CS enables you to easily draw objects that are located against another
object’s face.

Create the New Project 2-9
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3 - Draw the Model
This chapter contains the following topics:

l Create the Spherical Cavity
o Modify the Cavity Attributes
o Verify Lighting Attributes

l Draw the Dielectric Resonator
l Create the Annular Feed Ring
l Draw the Feed Gap
l Create the Air Volume
l Split the Model for Symmetry

DRA Geometry:
The dielectric resonator antenna (DRA) model consists of five basic objects, with parameters as
listed in the table below:

Air Volume 30 mm radius and a height of 35 mm

Spherical Cavity 25 mm radius

Spherical Dielec-
tric

12.5 mm radius

Annular Ring 5.8 mm outer radius and a width of 1.0 mm.

Feed Gap 1 mm thickness

Note:

All objects are centered at the global origin (0, 0, 0).

Create the Spherical Cavity
In order to create the antenna's spherical cavity, first draw a sphere and then split it to generate a
hemispherical solid. The steps are listed below.

1. On the Draw ribbon tab, click Draw sphere.
2. Draw a sphere with the global origin as its center and with a radius = 25mm, as follows:

Draw the Model 3-1
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a. Click on theGlobal Origin. The cursor becomes a black diamond to indicate snap-
ping points at the origin and all other grid points.

b. Press Tab to jump into the dX text box at the bottom of the EDT window. Specify the
following coordinates to define the Radius and then press Enter:

dX: 25, dY: 0, dZ: 0

Note:

Use the Tab key to navigate through the dX, dY, and dZ text boxes.

The sphere appears in the drawing region, and the Properties dialog box appears:

Figure 3-1: Sphere Properties – Command Tab

3. Ensure that the values in the Command tab of the Properties dialog box match the pre-
ceding figure.

4. In the Attribute tab of the Properties dialog box, change the object Name to Cavity.
5. DeselectMaterial Appearance, if it's currently selected, to use your default object color

and transparency settings rather than those specified in the materials library.
6. ClickOK to close the Properties dialog box.

For now, keep the sphere selected.

7. Press Ctrl+D to fit the sphere within the drawing region.

Draw the Model 3-2
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Figure 3-2: Sphere and History Tree in the ModelerWindow

8. On the Draw ribbon tab, click Split.

The Split dialog box appears.

9. Set all options on the Split dialog box as shown in the following figure and then clickOK:

Figure 3-3: Split Dialog Box for Cavity

Draw the Model 3-3
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The object Cavity is split, and only the negative half of the sphere remains.

10. Click in the Modeler window's background area to clear the current selection.

The color and transparency of your sphere may differ from the following image (depending
on your default appearance settings):

Figure 3-4: Cavity after Splitting

Modify Cavity Attributes
On this page, you will learn about an alternative method of modifying the attributes of the Cavity
object (other than the Properties dialog box used in the last page).

1. Click Cavity in the History Tree to display its attributes in the docked Properties window.

Note:

You can enable this window by selecting View > Properties from the menu bar,
if it is not currently displayed.

Draw the Model 3-4
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Figure 3-5: Cavity Attributes

2. Ensure that the selectedMaterial is "vacuum”, which is the initial default material for a
new HFSS design.

In the previous procedure, you ensured that theMaterial Appearance option was cleared.
In addition to assigning default color and transparency attributes, having this option
cleared enables you to override the default material appearance.

3. Click the color bar in the Value column of the Color row.

The Color palette appears.

4. Select red (row 2, column 1 of the predefined colors), as shown below:
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Figure 3-6: Color Palette

Verify that the RGB values are Red: 255, Green: 0, Blue: 0 and then clickOK.

5. Click the button in the Value column of the Transparent row.

The Set Transparency dialog box appears.

6. Enter 0.7 for the value of Transparency, as shown below, and clickOK:

Figure 3-7: Set Transparency Dialog Box

7. Click outside the object, on the Modeler window background, to deselect Cavity.

The object now has a translucent red appearance.

Verify Lighting Attributes
1. From the far right end of the View ribbon tab, clickModify Attributes > Lighting.

The Lighting Properties dialog box appears.
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Figure 3-8: Lighting Properties Dialog Box

2. Verify that the Do not use lighting option is cleared (not selected).

You can keep the remaining settings at their default values.

3. ClickOK.

Your completed Cavity object should resemble the figure below:
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Figure 3-9: The Cavity with Attribute Changes Applied

Draw the Dielectric Resonator
Now, draw another sphere, edit its attributes, and split it.

1. On the Draw ribbon tab, click Draw sphere.
2. Draw a sphere with its center at the origin and radius = 12.5 mm.
3. Ensure that the settings in the Command tab of the Properties dialog box match the fol-

lowing figure:

Figure 3-10: Properties for dielectric sphere

4. Click the Attribute tab and type Dielectric in the Name text box.
5. From theMaterial drop-down menu, choose Edit.

The Select Definition dialog box appears.

6. Click Add Material.

The View / Edit Material dialog box appears.
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7. Specify the new material properties as follows:
a. In theMaterial Name text box, type dra_diel.
b. In the Value column of the Relative Permittivity row, specify 9.5.

Figure 3-11: View / Edit Material Dialog Box – Dielectric Material Properties

c. ClickOK twice to close the View / Edit Materials and Select Definition dialog boxes.
8. Ensure that theMaterial Appearance option is not selected.
9. Change the Color to yellow (row 2, column 2 of the predefined palette colors: Red: 255,

Green: 255, Blue: 0).
10. Set the Transparent value at 0.7.
11. ClickOK but keep the Dielectric object selected for now.

Figure 3-12: The Dielectric Object Added

12. On the Draw ribbon tab, click Split.
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The Split dialog box appears.

13. Set all options on the Split dialog box as shown in the following figure and then clickOK:

Figure 3-13: Split Dialog Box for Dielectric

The object Dielectric is split into a hemispherical solid. Only the positive half of the original
sphere has been retained.

14. Clear the current selection. You model should look like the following figure:
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Figure 3-14: Dielectric after Splitting

Create the Annular Feed Ring
In this antenna model, the annular feed ring is the controlled aperture through which the E-fields
will radiate. Later on in the project, you will assign a perfect H boundary to the annular feed ring
to allow the E-fields to radiate through it. In this procedure, you will create the antenna’s annular
feed ring, which is the result of subtracting one circle from another. You will also specify the attrib-
utes of the new object.

Draw the Outside Circle:

1. On the Draw ribbon tab, click Draw circle.
a. Click the global origin to indicate the center point. The cursor will become a filled

circle at the proper snapping point, since this point is the center of the two hemi-
spherical objects previously drawn.

b. Enter the following values in the coordinate text boxes at the bottom of the EDT win-
dow:

l dX: 5.8
l dY: 0
l dZ: 0

c. Press Enter.

In the Properties dialog box that appears, verify that the properties under the Command
tab are as shown below:

Figure 3-15: Outside Circle Properties – Command Tab
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Note:

Alternatively, you could have drawn a random circle and then edited its location
and radius in the Command tab of the Properties dialog box.

2. On the Attribute tab of the Properties dialog box, change the object Name to Annu-
larRing.

Note:

The object is not yet an annular ring, but it will be soon. Editing the attributes now
is more efficient than reselecting the finished ring later and editing the attributes
at that time.

3. Ensure that theMaterial Appearance option is not selected.
4. Change the object Color to dark blue (row 5, column 5 of the predefined colors; Red: 0,

Green: 0, Blue: 128).
5. Set the Transparent to 0.5.
6. ClickOK to close the Properties dialog box.

The outside circle of the annular feed ring has been added to the model and is currently
selected:

Figure 3-16: Annular Feed Ring's Outside Circle Added to Model

Draw the Inside Circle:
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7. On the Draw ribbon tab, click Draw circle.
a. Click the global origin to indicate the center point. The cursor will become a filled

circle at the proper snapping point, since this point is the center of the two hemi-
spherical objects and the previously drawn circle.

b. Enter the following values in the coordinate text boxes at the bottom of the EDT win-
dow:

l dX: 4.8
l dY: 0
l dZ: 0

c. Press Enter.

In the Properties dialog box that appears, verify that the settings under the Command tab
are as shown below:

Figure 3-17: Inside Circle Properties – Command Tab

8. On the Attribute tab of the Properties dialog box, change the object Name to ID_Circle.

Note:

Because you renamed the first circle AnnularRing, the second circle was auto-
matically named Circle1 instead of Circle2. Renaming it to ID_Circle helps to
avoid confusion.

9. ClickOK to close the Properties dialog box.

Subtract ID_Circle from AnnularRing:

10. In the History Tree, click AnnularRing to select it.
11. Holding Ctrl, click ID_Circle to select it also.
12. In the Draw ribbon tab, click Subtract.
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13. In the Subtract dialog box that appears, verify that the settings are as shown below and
then clickOK.

Figure 3-18: Subtract Dialog Box

ID_Circle is subtracted from AnnularRing, and the resulting object is an actual annular ring
now.

Note:

The selection order determines which object is the Blank Part and which is the
Tool Part. However, you can move objects from one list to the other as needed
before performing the operation.

14. Clear the current selection.

You model should resemble the following figure:
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Figure 3-19: AnnularRing Completed

Draw the Feed Gap
The feed gap is the object through which the excitation is fed. You will first draw a rectangle that
extends through the annular feed ring. You will then intersect the ring and rectangle to reduce
the gap to only the area where the two objects overlap each other.

Draw the Gap Rectangle:

1. On the Draw ribbon tab, click Draw rectangle.
2. Click anywhere on the grid, move the mouse, and click again to draw a rectangle of any

arbitrary size and location.

As soon as you click the second point, the Properties dialog box appears.

3. On the Command tab of the Properties dialog box, specify the Position, XSize, and
YSize values, as shown in the following figure:
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Figure 3-20: Rectangle Properties – Command Tab

4. On the Attribute tab of the Properties dialog box, change the object Name toGap.
5. Ensure that theMaterial Appearance option is not selected.
6. Change the object Color to green (row 3, column 3 of the predefined colors; Red: 0,

Green: 255, Blue: 0).
7. Set the Transparent value to 0 (opaque).
8. ClickOK and then clear the current selection.

Figure 3-21: The Gap Rectangle Drawn

Intersect the Gap Rectangle and Annular Feed Ring:

9. In the History Tree, selectGap.
10. Hold down Ctrl and also select AnnularRing.

Draw the Model 3-16

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)

Note:

The selection order of these two objects is critical.

11. On the Draw ribbon tab, click Intersect.

The rectangle is trimmed to the two circles comprising the annular feed ring, forming the
completedGap object. The extraneous portions of the feed rectangle are removed, and
the object AnnularRing remains.

Figure 3-22: Feed Gap Completed

The selection order determines which object is cloned and retained after the intersection
operation (specifically, the first item selected).

Note:

If the AnnularRing object is not retained after the operation, recheck theGeneral
Options in the 3D Modeler >Operation group per the relevant instructions on
the Verify HFSS and Modeler Options page.

Create the Air Volume
To analyze radiation effects, create a virtual object that represents the radiation boundary. A
box-shaped area (rectangular prism) can also be created automatically, which is demonstrated
in other exercises. For this antenna model, you will manually create a radiation-transparent air
volume surface sufficiently far from the model. The shape will be an 18-sided regular polygon
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approximating a cylinder. The start position coordinates will be 30, 0, 0 mm and the height 35
mm.

Note:

The segmented quasi-cylindrical shape can help to produce a somewhat better quality
or more consistent mesh as compared to a smooth curved surface. Segmented planar
shapes are also very useful for visualizing the twist resulting from sweeping a face into
a solid when you specify a non-zero twist angle.

1. On the Draw ribbon tab, click Draw regular polyhedron.
2. Click the global origin (cursor turns to sphere at snapping point) to define the center of the

polygon base.
3. Click on two more randomly chosen points to set the initial diameter and height of the poly-

gon.

The Segment number dialog box appears as soon as you click for the third time.

Figure 3-23: Segment Number Dialog Box

4. Set Number of Segments to 18 and clickOK.

The Properties dialog box appears.

5. In the Command tab of the Properties dialog box, enter the values as shown in the fol-
lowing figure:
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Figure 3-24: Polyhedron Properties – Command Tab

6. In the Attribute tab of the Properties dialog box, change the Name from Polyhedron1 to
AirVolume.

7. Set theMaterial to "air" as follows:

Choose Select from theMaterial drop-down menu, select "air" from the Select Definition
dialog box, and clickOK to return to the Properties dialog box.

8. Ensure that theMaterial Appearance option is not selected.
9. Specify a bright blue-green Color (row 2, column 5 of the predefined palette colors; Red:

0, Green: 255, Blue: 255).
10. Set Transparent to 0.9.
11. ClickOK to accept the settings and close the Properties dialog box.
12. Press Ctrl+D if needed to fit the model to the display area and clear the current selection

to view the resulting color and transparency assignments.

Figure 3-25: Air Volume Completed

13. Save the project.
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Split the Model for Symmetry
This model, as constructed, is symmetrical about the YZ plane. Split the model along this plane
to take advantage of symmetry. The volume of the model is cut in half and, therefore, the number
of elements. The end result is a model that produces equally valid results but in a shorter time
and while consuming significantly less of the computer resources (that is, memory and hard disk
space).

1. Press Ctrl+A to select all objects in the model.

Alternatively, you can use the menu bar (Edit > Select All).

2. On the Draw ribbon tab, click Split.

The Split dialog box appears.

3. Select YZ from the Split using plane drop-down menu and Positive side as the Keep
result option:

Figure 3-26: Split Dialog Box

4. Accept the defaults for the remaining options and clickOK to split the entire model.
5. Clear the current selection.

Your final model should appear similar to the figure below:
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Figure 3-27: The Model After Split for YZ

6. Save the project.

You are now ready to assign ports and boundaries to your antenna model.
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4 - Setting Up the Problem
Now that you created the geometry and assigned the materials and other attributes for the
antenna problem, you are ready to define its boundaries and excitation ports.

This chapter contains the following topics:

l Define the boundary conditions, such as the location of the radiation boundary, the sym-
metry plane, and more.

l Define the lumped port through which the signal enters the antenna and modify its imped-
ance multiplier to account for symmetry.

l Verify that you correctly assigned the boundaries and excitations to the model.

Boundary Conditions
Boundaries specify the behavior of magnetic and electric fields at various surfaces. They can
also be used to identify special surfaces, such as resistors, whose characteristics differ from the
typical boundaries.

The following four types of boundary conditions are used for this antenna problem:

Radiation This type of boundary simulates an open region that allows waves to radiate
infinitely far into space, such as antenna designs. HFSS absorbs the wave
at the radiation boundary, essentially ballooning the boundary infinitely far
away from the structure. In this antenna model, the air volume object is
defined as a radiation boundary.

Perfect E This type of boundary models a perfectly conducting surface in a structure,
which forces the electric field to be normal to the surface. In this antenna
model, the bottom face of the air volume object is defined as a perfect E
boundary.

Perfect H This type of boundary forces the tangential component of the H-field to be
the same on both sides of the boundary. In this antenna model, the annular
feed ring is the aperture to which the Perfect H boundary is assigned.
Because the aperture is defined as a perfect H boundary, the E-fields will
radiate through it. If it were not defined as a perfect H boundary, the E-field
would not radiate through, and the signal would terminate at the aperture.

Symmetry In structures that have an electromagnetic plane of symmetry, such as this
antenna model, the problem can be simplified by modeling only one-half of
the actual device and identifying faces along the symmetry plane as a per-
fect H or perfect E boundary. For this antenna problem, a perfect H sym-
metry boundary is used.
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Assign a Radiation Boundary to the Air Volume
The first boundary you will assign is a radiation boundary to the entire air volume object. This
boundary is defined first because the Perfect E, Perfect H, and Symmetry boundaries you will
apply later must override the radiation boundary at a total of two Air Volume faces. Wherever
they coincide, subsequently applied boundary conditions override those applied at an earlier
time. You could apply the radiation boundary later, but then you would have to select the many
individual outside faces of the air volume object (excluding the Perfect E and Symmetry faces),
which is far less convenient.

Note:

Boundaries accidentally applied in the wrong order can be reordered via the menu bar
command, HFSS > Boundaries > Reprioritize.

Radiation boundary model surfaces represent open space. Energy is allowed to radiate from
these boundaries instead of being contained within them. A radiation surface does not have to
be spherical, but it must be exposed to the background (that is, surrounding environment), con-
vex with regard to the radiation source, and located at least a quarter wavelen gth from the radi-
ating source. In some cases the radiation boundary may be located closer than one-quarter
wavelength, such as portions of the radiation boundary where little radiated energy is expected.

To assign a radiation boundary to the air volume object:

1. Select AirVolume from the History Tree.
2. From the menu bar, click HFSS > Boundaries > Assign > Radiation.

The Radiation Boundary dialog box appears.

3. Verify that Name = Rad1.
4. ClickOK.

The resulting radiation boundary is applied to the object AirVolume and now appears as a
subentry under Boundaries in the Project Manager.

5. From the Draw ribbon tab, click Orient.

The default Trimetric view of the model is restored.

If the boundary visualization is not displayed, select Boundaries > Rad1 from the Project
Manager.
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Figure 4-1: Radiation Boundary Assigned to AirVolume

Note:

For this antenna problem, it is not necessary to edit any boundary’s visualization
default settings.

Tip:

To edit a boundary’s visualization settings:

1. From the menu bar, click HFSS > Boundaries > Visualization if you want to
show or hide boundaries. The Boundary Visualization Options window appears.

2. Deselect the View Geometry, View Name, or View Vector options of bound-
aries that you want to hide from view. Select the options you want to show in the
Modeler window. Visualization changes are applied immediately when a check-
box state is toggled.

3. Click Close when finished.
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Assign a Perfect E Boundary to the Air Volume
Next, you must define the intersection between the cavity and the air volume as a perfect E
boundary condition. The top of the cavity is a conducting layer, which is the ground plane of the
antenna. The area beyond the cavity radius continues to be a conducting layer. Therefore, you
will assign a perfect E boundary to the bottom face of the air volume object.

By default, all HFSS model surfaces without a user-defined boundary condition are assumed to
have perfectly conducting walls. The surfaces of all model objects that have been assigned per-
fectly conducting materials are automatically assigned perfect E boundaries. The electric field is
assumed to be normal to these surfaces. The final field solution must match the case in which
the tangential component of the electric field goes to zero at perfect E boundaries.

To assign a perfect E boundary to the bottom face of the air volume object:

1. Deselect the radiation boundary you just assigned.
2. Press F to begin the Face selection mode.
3. Select the bottom face of the object AirVolume as follows:

a. Select a face on the AirVolume object, taking care to click at a point where only the
bottom face is immediately behind the clicked point, as shown below:

b. Press B (for select Next Behind), and the AirVolume bottom will become the selec-
ted face. (If the cursor was too high when you clicked, the selection may be of the
top face of cavity, the spherical face of the dielectric, or the back face of the air
volume.)
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Figure 4-2: Bottom Face of AirVolume Selected

4. Right-click in the Modeler window and choose Assign Boundary > Perfect E from the
shortcut menu.

The Perfect E Boundary dialog box appears.

5. Ensure that Infinite Ground Plane is cleared (not selected).

Note:

If selected, this option simulates the effects of an infinite ground plane. It only
affects the calculation of near- and far-field radiation during post processing. The
3D Post Processor models the boundary as a finite portion of an infinite, perfectly
conducting plane.

Figure 4-3: Perfect E Boundary

6. ClickOK.
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The resulting perfect E boundary condition is assigned to the bottom face of the object
AirVolume:

Figure 4-4: Perfect E Boundary Applied

Assign a Perfect H Boundary to the Annular Ring
Next, assign is a perfect H boundary to the annular ring. Over the annular ring area, this bound-
ary will supersede the Perfect H boundary you just assigned to the annular ring. So, as you can
see again, the order of application of boundary conditions is important when they overlap.

A perfect H boundary represents a surface at which the tangential component of the H-field is
the same on both sides. For internal planes, such as the annular ring in this antenna model, this
assignment results in a natural boundary through which the field propagates. For planes on the
outer surface of the model, this assignment results in a boundary that simulates a perfect mag-
netic conductor, in which the tangential component of the H-field is zero.

From the previous operation, you should still be in the Face selection mode. To assign a perfect
H boundary to the face of annular ring:

1. Deselect the perfect E boundary you just assigned.
2. On the History Tree, select AnnularRing.
3. Right-click in the Modeler window and choose Assign > Boundary > Perfect H.

The Perfect H Boundary dialog box appears.

4. ClickOK.

The Perfect H boundary is assigned:
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Figure 4-5: Perfect H Boundary Assigned

5. Clear the Perfect H boundary selection.

Assign a Symmetry Boundary to the Model
HFSS has a boundary condition specifically for symmetry planes. Instead of defining a perfect E
or perfect H boundary, you define a perfect E or perfect H symmetry plane.

When you are defining a symmetry plane, you must decide which type of symmetry boundary
should be used, Perfect E or Perfect H. In general, use the following guidelines to decide which
type of symmetry plane to use:

l If the symmetry is such that the E-field is normal to the symmetry plane, use a perfect E
symmetry plane.

l If the symmetry is such that the E-field is tangential to the symmetry plane, use a perfect H
symmetry plane.

The simple two-port rectangular waveguide shown below illustrates the differences between the
two types of symmetry planes. The E-field of the dominant mode signal (TE10) is shown. The
waveguide has two planes of symmetry, one vertically through the center and one horizontally.

l The horizontal plane of symmetry is a Perfect E surface. The E-field is normal and the H-
field tangential to that surface.

l The vertical plane of symmetry is a Perfect H surface. The E-field is tangential and the H-
field normal to that surface.
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Figure 4-6: Electric Field and Symmetry planes

Because the antenna model in this guide has a vertical plane of symmetry and the E-field is tan-
gential to the surface, apply a Perfect H boundary to the faces along the symmetry plane.

You will assign a perfect H symmetry boundary to the splitting plane faces of the objects
AirVolume and Cavity (about which the model is symmetrical).

Note:

You do not need to apply the symmetry boundary condition to the cut face of the object
Dielectric, because this object is fully encompassed by the AirVolume. Therefore, the
cut face of AirVolume includes the area corresponding to the cut face of Dielectric.
HFSS also includes logic to override, throughout a region of overlapping volumes, the
material properties of a larger object with the material properties of a smaller object that
it envelopes . So, it is also not necessary for you to subtract the Dielectric volume from
the AirVolume. However, if you did choose to subtract the Dielectric volume from the
AirVolume, then you would have to apply the symmetry boundary condition to the cut
face of the Dielectric too. (In that case, the cut face of the object AirVolume would no
longer encompass the Dielectric face.)

From the previous operations, you should still be in the Face selection mode. To assign a perfect
H symmetry boundary to the model’s symmetry plane:

1. From the Draw ribbon tab, click Orient > Back (+X).
2. Select the symmetry faces (that is, those along the YZ splitting plane) of AirVolume and

Cavity, as shown below:
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Figure 4-7: Symmetry Faces Selected

3. From the menu bar, click HFSS > Boundaries > Assign > Symmetry.

The Symmetry Boundary dialog box appears.

4. Verify that the default name is Sym1.
5. Select Perfect H as the Symmetry type, and clickOK.

The resulting perfect H symmetry boundary condition is assigned to the faces of the
objects AirVolume and Cavity.

If the boundary visualization is not displayed, select Boundaries > Sym1 from the Project
Manager.
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Figure 4-8: Symmetry Boundary Applied

6. Clear the current selection.

7. You have completed the boundary application phase. It's a good time to Save the
model.

Next, you will apply excitations.

Excitation Conditions
Ports define surfaces exposed to non-existent materials (generally the background or materials
defined to be perfect conductors), through which excitation signals enter and leave the structure.
One lumped port will be defined for this antenna problem. Lumped ports are similar to traditional
wave ports, but can be located internally and have a complex user-defined impedance. Lumped
ports compute S-parameters directly at the port. A lumped port can be defined as a rectangle
from the edge of a trace to the ground or as a traditional wave port. The default boundary is per-
fect H on all edges that do not come in contact with a conductor.

Assign a Lumped Port Across the Gap
For this antenna problem, the engineering focus is on the behavior of the antenna itself, not its
feed. Therefore, the model will feed with a lumped port across the annular slot, or gap object.
Lumped ports are similar to traditional wave ports, but can be located internally and have a com-
plex user-defined impedance. Lumped ports compute S-parameters directly at the port. A
lumped port can be defined as a rectangle from the edge of the trace to the ground, as in this
antenna problem, or as a traditional wave port. The default boundary is perfect H on all edges
that do not come in contact with the metal.
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Note:

The setup of a lumped port varies slightly depending on whether the solution is modal
or terminal. As a reminder, the solution type for this antenna problem is modal driven.

To assign a lumped port across the gap object:

1. From the Draw ribbon tab, click Orient to restore the default Trimetric view orientation.
2. In the History Tree, clickGap to select it:

Note:

Recall thatGap is the rectangle you renamed (it's a planar sheet object with no
material assignment). You should look under Sheets > Unassigned.

3. Zoom in on the area where the gap object is located to see it clearly. The easiest way to do
so is to place the cursor at the center of the area of focus and roll the mouse wheel upward
(away from you). This moves the viewpoint camera closer to the model.

Figure 4-9: Gap Selected

4. From the menu bar, click HFSS > Excitations > Assign > Port > Lumped Port.

The Lumped Port dialog box appears displaying theGeneral step of the lumped port setup
process.
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Note:

The first time you assign a lumped port, HFSS walks you through the process
with a step-by-step wizard.

5. Enter the Name and Full Port Impedance values as shown in the following figure:

Figure 4-10: Lumped Port : General Dialog Box

6. Click Next.
7. In the Lumped Port : Modes step, click in the Integration Line column ofMode 1 and

select New Line.

The cursor changes to a dotted line and theMeasure Data and Create Line dialog boxes
appear.

8. Click the start point (0, 5.8, 0), as shown in the figure below. This is the vertex at the +Y
end of the longGap edge that lies along the symmetry boundary. The cursor also
becomes a solid black square at the endpoints of the gap edges (snapping point).

Figure 4-11: Measure Data – Integration Line Start Point
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Note:

Use the Measure Data dialog box as reference as you move your cursor to reach
(0, 5.8, 0).

9. Click the end point (0, 4.8, 0) as shown in the following figure. This is the vertex at the -Y
end of the longGap edge that lies along the symmetry boundary.

Figure 4-12: Measure Data – Integration Line Endpoint

Note:

The two points defines the direction and length of the integration line.

The Lumped Port dialog box reappears as soon as you click the second point.

10. Click Next.

The Lumped Port : Post Processing step appears.

11. Select Do Not Renormalize and click Finish.

The resulting lumped port is assigned across the objectGap.

12. To display the lumped port and integration line visualization, select Excitations >
LumpPort1 in the Project Manager.
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Figure 4-13: Lumped Port Assigned

13. On the Draw ribbon tab, click Fit All to fit the full model to the viewing area.
14. Click in the Modeler window's background area to clear the current selection.

Modify the Impedance Multiplier
Because you cut the full model in half and defined a symmetry plane, the computations must be
adjusted by specifying an impedance multiplier.

In cases such as this antenna problem, where a perfect H symmetry plane splits a structure in
two, only one-half of the power flow is seen by the system, but the full voltage differential is
present. Therefore, such half-symmetry models result in computed impedances that are twice
those of the full structure. To account for this effect, you must specify an impedance multiplier of
0.5.

To edit the impedance multiplier:

1. Right-click Excitations in the Project Manager and select Edit Port Impedance Mul-
tiplier from the shortcut menu.

The Edit Port Impedance Multiplier dialog box appears.

2. Enter 0.5 for the Set the port impedance multiplier for the design value:
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Figure 4-14: Edit Port Impedance Multiplier Dialog Box

3. ClickOK.

Verify All Boundary and Excitation Assignments
Now that you have assigned all the necessary boundaries and excitations to the model, you
should review them in the solver view. When you verify boundaries and excitations in the solver
view, you review their locations as you have defined them for generating a solution (solving).

As you have seen previously, you can select specific Boundaries or Excitations in the Project
Manager to display their visualizations on the model. The Solver View of Boundaries identifies
the boundaries and excitations differently. It uses solid, user-customizable colors that remain vis-
ible as you select or deselect objects or manipulate the model view (as long as you leave the
Solver View of Boundaries dialog box open).

To check the solver’s view of boundaries and excitations:

1. From the menu bar, click HFSS > Boundary Display (Solver View).

HFSS runs an initial mesh and determines the locations of the boundaries and excitations
on the model.

The Solver View of Boundaries dialog box appears, which lists all the boundaries and
excitations for the active model in the order in which they were assigned (or the order spe-
cified in the Reprioritize Boundaries and Excitations dialog box. It also shows the default
boundary that is assigned automatically by the program to outer faces that lack a user-spe-
cified boundary condition.

Important:

The order of the boundary and excitations in this dialog box is important. If two
assignments overlap on the model (such as PerfE1, PerfH1, and LumpPort1),
the latter assignment overrides the former assignment. Be sure that the assign-
ments on smaller faces are not being overridden by the assignment of a larger
overlapping face, due to an error in the order of the boundaries and excitations.

2. Select the four checkboxes in the Visibility column indicated in the following figure:
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Figure 4-15: Solver View of Boundaries Dialog Box

Notice that the four colors associated with PerfE1, PerfH1, Sym1, and LumpPort1 are all
visible on the model and that they are in the proper order to prevent any boundary or excit-
ation from being incorrectly overridden:
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Figure 4-16: Solver View of Boundaries – PerfE1, PerfH1, Sym1, and LumpPort1
Selected
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Note:

l Visible to Solver appears in the Solver Visibility column for each bound-
ary that is valid (that is, represented in the solution).

l Overridden will appear in the Solver Visibility column for any boundary
or excitation that is completely overridden by a boundary or excitation that
overlaps it (that is, not represented in the solution). LumpPort1 locally over-
rides a portion of PerfH1, and both of these two boundaries locally override
a portion of PerfE1. However, PerfE1 is not listed as "Overridden" because
it is still visible to the solver (therefore, it participates in the solution). Actu-
ally, the vast majority of PerfE1 is intact.

3. Verify that the boundaries or excitations you assigned to the model are being displayed as
intended for solving purposes. (See the preceding two figures.)

4. Modify the parameters or priority for those boundaries or excitations, if any, that are not
being displayed as intended.

5. Click Close, and then click Save.

You are now ready to set up the solution parameters for this antenna problem and generate a
solution.
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5 - Generating a Solution
Now that you have created the geometry and set up the model, you are ready to generate a solu-
tion.

Your goals for this chapter are to:

l Set up the solution parameters
o Add a frequency sweep to the solution.

l Define meshing instructions.
l Validate the project setup.
l Generate a solution.
l View the solution data:

o Profile
o Convergence
o Matrix

Add Solution Setup
Now, you will specify how HFSS will compute the solution by adding a solution setup to the
antenna project’s design.

To add a solution setup to the design:

1. On the Simulation ribbon tab, click Setup > Advanced.

The Solution Setup dialog box appears:

2. Under theGeneral tab, enter the values shown in the following figure:
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Figure 5-1: Driven Solution Setup Dialog Box – General Tab

3. Select theMesh/Solution Options tab.
4. In the Initial Mesh Options section, deselect Use Default Value and enter the Lambda

Target value shown in the following figure:

Figure 5-2: Driven Solution Setup Dialog Box – Mesh/Solution Options Tab
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5. ClickOK.

The Edit Frequency Sweep dialog box opens automatically when you first add an
advanced solution setup to an HFSS design that already has at least one port assigned.
Leave this dialog box open and continue to the next page for instructions on defining the
sweep.

Add a Frequency Sweep to the Solution Setup
To generate a solution across a range of frequencies, add a frequency sweep to the solution
setup. HFSS performs the sweep after the adaptive solution.

For this antenna model, you will add a Fast frequency sweep to the solution setup. A Fast sweep
generates a unique full-field solution for each division within a frequency range. It is best for mod-
els that will abruptly resonate or change operation in the frequency band, and obtains an accur-
ate representation of the behavior near the resonance.

The Edit Frequency Sweep dialog box should already be open as a result of adding the solution
setup in the previous procedure.

Define a fast frequency sweep as follows:
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1. Enter the settings shown in the following figure:

Figure 5-3: Edit Frequency Sweep Dialog Box

Note:

If you do not select Save Fields, the field solution will not be saved for each
solved point in the frequency sweep. Therefore, the field solutions will not be
available during post processing.

2. Optionally, click Preview to display each of the sweep values within the frequency range
at the 0.01 GHz step size increment you specified. Click Close when finished looking at
the 251 sweep points.

3. ClickOK to add the sweep and close the dialog box.

Setup1 and Sweep1 appear under Analysis in the Project Manager:
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Figure 5-4: Setup1 and its Sweep Listed in the Project Manager

Define Mesh Operations
In HFSS, mesh operations are optional mesh refinement settings that you specify before a mesh
is generated. The technique of providing HFSS with mesh construction guidance is referred to
as “seeding” the mesh.

Since the fields in the annular feed ring are very important in this antenna model, you will provide
some meshing instructions at this object. Specifically, you will assign a length-based mesh
refinement to the annular feed ring. This refinement instructs HFSS to reduce the length of tet-
rahedral elements in the designated area until they are below a specified value. The length of a
tetrahedral element is defined as the length of its longest edge.

You can specify the maximum length of tetrahedra on faces or inside of objects. You can also
specify the maximum number of elements that are added during the refinement. The refinement
criteria you specify is used to guide the meshing process, affecting the size and number of ele-
ments generated.

To assign a length-based mesh refinement to the annular feed ring:

1. Select Annular_Ring under Sheets > Perfect H in the History Tree.
2. Using the menu bar, click HFSS >Mesh > Assign Mesh Operation >On Selection >

Length Based.

Note:

Applying theOn Selection command refines every face of the selected object or
objects. However, in this case, Annular_Ring only has one face.

The Element Length Based Refinement dialog box appears.

3. Restrict the length of tetrahedra edges touching the faces, as detailed in the bullet points
and figure below:

l Ensure that Set maximum element length is selected.
l Enter 0.5 mm in the text box to the right of this option.
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Figure 5-5: Element Length Based Refinement Dialog Box

Note:

HFSS refines the element edges touching the selected faces or faces until they
are equal to or less than the specified value.

4. Accept the default name Length1.
5. Ensure thatMaximum number of additional elements is cleared (not selected.

Note:

If selected, this option restricts the number of elements added during the refine-
ment process, even if the size criterion has not been satisfied.

6. ClickOK.

The Length1 refinement now appears underMesh in the Project Manager.

7. Save the changes you've made to your project.

Validate the Project Setup
Before you run an analysis on the antenna model, it is important to first perform a validation
check on the project. HFSS runs a check on all the setup details of the active project to verify that
the necessary steps have been completed and their parameters are reasonable.

To perform a validation check on the project DRA:

Generating a Solution 5-6

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)

1. On the Simulation ribbon tab, click Validate.

The Validation Check window appears, and HFSS checks the project setup.

2. View the results in the Validation Check window:

Figure 5-6: Validation CheckWindow

Note:

For this antenna project, a warning triangle appears at Boundaries and Excit-
ations. There are several associated warnings in the Message Manager window
concerning overlapping boundaries. Using the solver view of the boundaries, you
have already verified that the solver will use the correct boundary for each face.
You can disregard the warnings and run the simulation.

3. Click Close.

4. Save the changes you've made to your project.

Generate the Solution
Now that you have entered all the appropriate solution criteria and defined the mesh operations,
the antenna problem is ready to be solved.

When you set up the solution criteria, you specified values for an adaptive analysis. An adaptive
analysis is a solution process in which the mesh is refined iteratively in regions where the error is
high, which increases the solution’s accuracy. You set the criteria that control mesh refinement
during an adaptive field solution. Many problems can be solved using only adaptive refinement.
Others may require five, ten, or more iterations to converge. For this exercise, you also specified
that a minimum of two converged iterations are to be completed. The first time the convergence
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criterion is satisfied, an additional iteration will be executed, after which the adaptations cease
(assuming the additional iteration also satisfies the convergence criterion).

The following is the general process carried out during an adaptive analysis:

1. HFSS generates an initial mesh.
2. Using the initial mesh, HFSS computes the electromagnetic fields that exist inside the

structure when it is excited at the solution frequency. (If you are running a frequency
sweep, an adaptive solution is performed only at the specified solution frequency.)

3. Based on the current finite element solution, HFSS estimates the regions of the problem
domain where significant solution error exists. Tetrahedra in these regions are refined.

4. HFSS generates another solution using the refined mesh.
5. The software recomputes the error, and the iterative process (solve— error analysis —

refine) repeats until the convergence criteria are satisfied or the requested number of
adaptive passes are complete.

6. If a frequency sweep is being performed, HFSS then solves the problem at the other fre-
quency points without further mesh refinement.

To begin the solution process:

1. On the Simulation ribbon tab, click Analyze All. This command solves every solu-
tion setup in the design, though, in this design, there is only one solution setup.

HFSS computes the 3D field solution inside the structure.

The Progress window displays the solution progress as it occurs:

Figure 5-7: ProgressWindow While Solving

Note:

The results that you obtain should be approximately the same as the ones given
in this getting started guide. However, there may be a slight variation between
platforms and software versions.
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View the Solution Data
While the analysis is running, you can view a variety of solution data, as follows:

1. On the Results tab ribbon, click Solution Data.

The Solutions window appears.

Note:

Subsequent topics describe the tabs that constitute the Solutions window:

l Profile
l Convergence
l Matrix Data
l Mesh Statistics

Leave the Solutions window open while reviewing the contents of each tab.

View the Profile Data
While the solution proceeds, examine the profile data, or computing resources, that were used
by HFSS during the analysis.

The profile data is essentially a log of the tasks performed by HFSS during the solution. The log
indicates the length of time each task took and how much RAM/disk memory was required.

To view the solution’s profile data:
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1. In the Solutions window, select the Profile tab, if it's not already selected.

Figure 5-8: SolutionsWindow – Profile Tab

Note:

To view the profile data if the Solutions window is not already open, right-click
Setup1 under Analysis in the Project Manager and choose Profile.

Notice that Setup1 is selected as the solution setup in the Simulation drop-down menu. By
default, the most recently solved solution is selected.

For the Setup1 solution, you can view the following profile data:

Task Lists the software module that performed a task during the solution
process, and the type of task that was performed.

For example, for the task mesh3d_adapt, Mesh3d is the software mod-
ule that adaptively refined the mesh.

Real Time The amount of real time (clock time) required to perform the task.

CPU Time The amount of CPU (Central Processing Unit) time required to per-
form the task.
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Memory The amount of RAM/virtual memory required of your machine to com-
plete the task. This value includes the memory required of all applic-
ations running at the time, not just HFSS.

Information The number of triangles, tetrahedra, and matrices generated.

2. Keep the Solutions window open and proceed to the next topic.

View Convergence Data
Next, view the convergence data, as follows:

1. In the Solutions window, select the Convergence tab.

Figure 5-9: SolutionsWindow – Convergence Tab

You can view the following convergence data while the solution is still running:

l Number of adaptive passes completed
l Number of tetrahedra created at each completed adaptive pass
l Setup data (such as theMaximum allowed Number of Passes and the Target num-
ber of converged Consecutive Passes)

l For solutions with ports, as in Setup1, you can view the maximum change in the
magnitude of the S-matrix coefficients between two consecutive passes, which is
the convergence criterion. This information is available after two or more passes
have been completed.
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When the solution is complete, you can view the total number of adaptive passes that
were performed and whether convergence was achieved. If the solution converged within
the specified stopping criteria, fewer passes than requested may have been performed.

The convergence data can be displayed in table format or on a rectangular (X - Y) plot.

2. Select Plot to see a graph of the convergence history.

Figure 5-10: Convergence Plot

3. Keep the Solutions window open and proceed to the next topic.

View Matrix Data
Next, view matrices computed for the S-parameters, impedances, and propagation constants
during each adaptive and sweep solution.

To view matrices:

1. In the Solutions window, select theMatrix Data tab.
2. In the second Simulation drop-down menu, choose Sweep.

This option displays the matrix data for a selected sweep frequency or for every frequency
in the sweep range.

3. Under the View subtab, select Display All Frequencies.
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4. Also under the View subtab, ensure that the S Matrix option is selected as the type of mat-
rix data you want to view.

5. Under the Format subtab, ensure that theMagnitude/Phase(deg) option is selected from
the pull-down list as the format in which to display the matrix information.

Your results should resemble the following image:

Figure 5-11: SolutionsWindow – Matrix Data Tab
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Note:

You can display matrix data in the following formats:

Magnitude/Phase Displays the magnitude and phase of the matrix
type.

Real/Imaginary Displays the real and imaginary parts of the matrix
type.

dB/Phase Displays the magnitude in decibels and phase of the
matrix type.

Phase Displays the phase of the matrix type.

Real Displays the real parts of the matrix type.

Magnitude Displays the magnitude of the matrix type.

Imaginary Displays the imaginary parts of the matrix type.

dB Displays the magnitude in decibels of the matrix
type.

6. Alternatively, to show the matrix entries for one solved frequency, deselect Display All
Freqs. Then, use the drop-down menu to select the solved frequency for which you want
to view matrix entries.

For adaptive passes, only the solution frequency specified in the Solution Setup dialog
box is available. For frequency sweeps, the entire frequency range is available.

7. Keep the Solutions window open and proceed to the next topic.

View Mesh Statistics
Finally, view the mesh statistics for the DielectricResonatorAntenna HFSS solution, as follows:

1. In the Solutions window, select theMesh Statistics tab to view data about the generated
tetrahedral elements.
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Figure 5-12: SolutionsWindow – Mesh Statistics Tab

The mesh statistics are listed separately for each part comprising the model, along with
the total number of elements (reported above the table). The following mesh statistics are
listed on this tab:

l Minimum, maximum, and RMS tetrahedra edge lengths
l Minimum, maximum, and mean tetrahedra volume
l Standard deviation of the tetrahedra volume.

Note:

You can click and drag the column header borders to resize any column width.
You can also increase the Solutions window's overall size by clicking and drag-
ging its outside border.

2. Click Close to exit the Solutions window.

Once the analysis has finished successfully, you can evaluate the results, as described in the
next chapter.
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6 - Evaluating the Results
Now that HFSS has generated a solution for the antenna problem, you can display and evaluate
the results in many different ways. You can:

l Plot field overlays (representations of basic or derived field quantities) on surfaces or
objects.

l Create 2D or 3D rectangular or circular plots and data tables of S-parameters, basic and
derived field quantities, and radiated field data.

l Plot the finite element mesh on surfaces or within 3D objects.
l Create animations of field quantities, the finite element mesh, and defined project vari-
ables.

l Scale an excitation’s magnitude and modify its phase.
l Delete solution data that you do not want to store.

For this antenna problem, you will specifically:

l Create Modal S-parameter reports.
l Create a field overlay plot of the magnitude of E on the top face of the antenna’s cavity.
l Create an animation of the mag-E plot.

Time It should take you approximately 1 hour to
work through this chapter.

Create an S-Parameters Report
To generate a rectangular (2D) plot of S(LumpPort1,LumpPort1):

1. On the Results ribbon tab, click Modal Solution Data Report > 2D.

The Report dialog box appears.
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Figure 6-1: Report Dialog Box – S Parameter Settings

2. Verify that Setup1 : Sweep is selected from the Solution drop-down menu.
3. Verify that Sweep is selected from the Domain drop-down menu.
4. Verify that the Default option (Freq) is selected for the X axis.

The remaining settings control the plotted Y values:

5. Specify the following information to plot along the y-axis:

Category S Parameter
This is the type of information to plot.

Quantity S(LumpPort1,LumpPort1)
This is the value to plot.

Function dB
This is the mathematical function of the quantity to
plot.

6. In the Families tab, ensure that the Sweeps option is selected.
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7. Click New Report but leave the Report dialog box open. You will be adding another report
in the next topic.

The S Parameter Plot 1 report window appears and is listed under Results in the Project
Manager. A trace icon with a description of the plotted Y value is also listed under S Para-
meter Plot 1. A trace is a single line that connects the related data points on the graph. A
single graph can contain multiple traces.

Figure 6-2: S Parameter Plot 1 – S(LumpPort1,LumpPort1), dB

Create a Z-Parameters Report
The Report dialog box should still be open from the previous plot generation procedure. If you

accidentally closed it, click Modal Solution Data Report > 2D on the Results
ribbon tab. To generate a 2D report of Z(LumpPort1,LumpPort1) Real and Imaginary traces:

Evaluating the Results 6-3
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1. In the Report dialog box, select the Trace tab.

Leave the Solution, Domain, Primary Sweep, and X axis settings as defined for the pre-
vious plot.

2. In the Y axis settings, add the first of two traces to a new plot, as follows:
a. Specify the values from the table below for the real trace:

Category Z Parameter

Quantity Z(LumpPort1,LumpPort1)

Function re
This is the real part of the complex number.

b. Click New Report, but do not click Close.

The Z Parameter Plot 1 report window appears with the real values plotted. The new plot
and trace are also listed under Results in the Project Manager.

3. In the Y axis settings, add the second of two traces to the plot just created, as follows:
a. Specify the function from the table below for the imaginary trace. Leave all other set-

tings as they are:

Function im
This is the imaginary part of the complex number.

b. Click Add Trace.
c. Close the Report dialog box.

The imaginary trace is added to Z Parameter Plot 1 and is also listed under Results in the
Project Manager.
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Figure 6-3: Z Parameter Plot 1 – Z(LumpPort1,LumpPort1), Real and Imaginary
Traces

Create a Mag E Field Overlay Plot
Now, you are ready to create and examine an E-field magnitude plot, overlaid on the bottom face
of the air volume object.

1. Use theWindowmenu to return to the Modeler window.

2. On the Draw ribbon tab, click Grid to toggle off the visibility of the drawing grid for a
cleaner view of the fields overlay.

3. Click in the Modeler window background and press F to ensure that you're in the Select
Facesmode.

4. Select the bottom face of the object AirVolume.
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Note:

As previously demonstrated, this selection can be made without changing the
model viewpoint. Click the cursor near the bottom of one of the rectangular
facets, and then press B to select the face that is Next Behind the clicked point on
the outer face.

5. Right-click Field Overlays in the Project Manager and select Plot Fields > E >Mag_E
from the shortcut menu.

The Create Field Plot dialog box appears:

Figure 6-4: Create Field Plot Dialog Box

6. From the Solution drop-down menu, select Setup1 : Sweep.
7. From the Freq drop-down menu, select 3.45GHz, which is the approximate frequency at

which the minimum S-Parameter result occurs.
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Note:

This drop-down menu includes a list of all frequencies for which a field solution is
available. If Setup1 : LastAdaptive were selected as the Solution option, only the
adaptive frequency of 3.5 GHz would be available in the Freqmenu.

8. Verify that 0deg is selected from the Phase drop-down menu.
9. SelectMag_E from theQuantity list.

This result is the magnitude of the real part of the electric field E(x,y,z,t).

10. Select AllObjects from the In Volume list.

This option instructs HFSS to plot over the entire volume of the model.

11. Click Done.

TheMag_E1 field overlay cloud plot appears in the Modeler window and is now listed
under Field Overlays > E Field in the Project Manager.

Your field overlay plot should resemble the one shown below:
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Figure 6-5: Initial E Field Overlay Plot

Modify the Mag E Plot Attributes
Now, you will modify the attributes of theMag_E1 field overlay plot you just created to prepare it
for an effective animation.

1. Double-click within the E Field [V/m] plot legend rectangle.

A dialog box appears that has settings for the various plot and legend attributes.

Evaluating the Results 6-8

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)

Figure 6-6: [DRA] DielectricResonatorAntenna -- E Field Dialog Box

2. In the Color map tab, specify the following settings:

Type Select Spectrum and Rainbow from the pull-down list.

Field quantities are plotted in multiple colors. Each field value is
assigned a color from the selected spectrum.

Real time
mode

Select this option, which immediately applies changes to the plot’s
attributes as you define them.

3. Select the Scale tab, and then specify the following settings:

Use Limits Select this option.

Only the field values between the minimum and maximum values
will be plotted. Field values below or above these values will be
plotted in the colors assigned to the minimum or maximum limits,
respectively.

Min Enter 3.

Max Enter 30000.

Linear/Log Select Log.
Field values will be plotted on a logarithmic scale.

Type Choose Decimal from the drop-down menu.

Width Enter 10.

Precision Enter 2.

4. Select the Plots tab, and then specify the following settings:
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IsoValType Select Tone from the pull-down list.

This isosurface display type varies color continuously between iso-
values.

Outline Select this option to outline the color bands corresponding to the
legend V/m increments.

Map transp. Clear this option, if it is selected.

If selected, the transparency of field values increases as the solu-
tion values decrease.

Note:

With Real Time Mode selected, most changes are applied immediately (as
entered) and the Apply button is grayed out.

5. Accept all the remaining default settings in this dialog box and click Close.

Your modified plotMag_E1 should resemble the one shown below:
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Figure 6-7: Modified E Field Plot Overlay

Create a Phase Animation of the Mag E Plot
Next, you will create an animation of the field overlay plot of the magnitude of E to examine a
frame-by-frame, animated behavior of the plot.

To create a phase animation of the Mag E plot:

1. Right-clickMag_E1 under Field Overlays > E Field in the Project Manager and click Anim-
ate.

The Create Animation Setup dialog box appears.
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Figure 6-8: Create Animation Setup Dialog Box

2. Accept the default name Animation1 in the Name text box.
3. Optionally, type a description of the animation in the Description text box. If you do not

type a description, a default one will be added after you finish creating the animation.
4. Under the Swept Variable tab, ensure that Single Variable and Phase are selected from

the two drop-down menus.
5. Accept the remaining default settings in the Start, Stop, and Steps text boxes for the

phase values of the animation.

If the Start value is 0deg, the Stop value is 170deg, and the number of steps is 17, the
animation will display the plot for 17 phase increments between 0 and 170. Therefore, the
phase angle increment will be 10 degrees. The start value (0deg) will be the first frame dis-
played, and a total of 18 frames will comprise the animation.

6. ClickOK.

The animation begins in the Modeler window. The play panel appears in the upper-left
corner of the desktop, enabling you to stop, restart, and control the speed and sequence
of the frames.
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Figure 6-9: E Field Animation

7. Use the player controls to pause, restart, or reverse the animation and to adjust its play-
back speed.

8. Click Close when you're done viewing the animation.
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7 - Optionally, Restore Current View
Orientations

You have completed this getting started guide.

If you prefer to use the new view orientations implemented in version 2024 R1 of the Ansys Elec-
tronics Desktop application, clear the Use Legacy View Orientation option as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is cleared:

3. ClickOK.

The settings in the 3D UI Options dialog box are global. Your choice is retained for all future pro-
gram sessions, projects, and design types that use the 3D Modeler or that produce 3D plots of
results.

Optionally, Restore Current View Orientations 7-1

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)

You can now save and close this project.

Optionally, Restore Current View Orientations 7-2

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)

Index-1

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Dielectric Resonator Antenna (DRA)

Index

.

.hfss file 2-1

#

3D Modeler window, defined 1-3

A

adaptive solution 5-1

air volume 3-17

assigning perfect E boundary
to 4-3

assigning radiation boundary
to 4-2

animation

creating a phase animation 7-1

animation, creating a phase anim-
ation 6-11, 6-11

annular feed ring 3-11

annular feed ring, assigning perfect
H boundary to 4-6

B

boundaries

about 4-1

assigning a perfect E
boundary 4-3

assigning a perfect H
boundary 4-6

assigning a radiation
boundary 4-2

assigning a symmetry boundary 4-7

editing visualization settings of 4-2

model-specific conditions 4-1

solver view of 4-15

verifying 4-15

D

dialog boxes

Create Field Plot 6-5

Edit Sweep 5-3

Element Length based refinement 5-6

Lumped Port wizard 4-10

Port Impedance Multiplier 4-14

Setup Animation 6-11

Solution Setup 5-1

Split 3-1

Symmetry Boundary 4-7

Traces 6-1

drawing

the air volume object 3-17

the annular feed ring object 3-11

the DRA object 3-9

the feed gap object 3-15

E

E-field

animating 6-11

plotting 6-5

elements, meshing 1-2
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excitations

about 4-10

impedance multiplier 4-14

model-specific conditions 4-10

solver view of 4-15

verifying 4-15

F

feed gap 3-15

feed gap, assigning lumped port
to 4-10

field overlay plots

modifying attributes of 6-8

finite element method 1-2

frequency sweep

adding 5-3

defining the sweep 5-3

saving fields 5-3

G

geometric model

assigning symmetry boundary
to 4-7

fitting in drawing region 3-1

sample problem 1-1

solution parameters 5-1

splitting for symmetry 3-19

graphical user interface 1-3

H

HFSS, interface overview 1-3

history tree, defined 1-3

I

impedance multiplier

about 4-14

modifying 4-14

L

lighting

ambient 3-6

disable attributes 3-6

distant 3-6

lumped port 4-10

lumped ports

impedance multiplier 4-14

M

mag E

field overlay plots of 6-5

plotting 6-5

menu bar, defined 1-3

mesh

defining mesh operations 5-5

elements 1-3

example of 1-2, 1-2

refining 5-5

seeding 5-5

mesh operations 5-5

restricting length 5-5
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Message Manager window,
defined 1-3

O

objects

air volume 3-17

annular feed ring 3-11

assigning lumped ports to 4-10

feed gap 3-15

splitting 3-1

splitting for symmetry 3-19

P

perfect E boundary

assigning 4-3

defined 4-1

perfect H boundary

assigning 4-6

defined 4-1

plots

animating 6-11, 6-11, 7-1

appearance in the project tree 6-
1, 6-3

creating a cloud plot 6-5

creating a mag E plot 6-5

modifying attributes of 6-8

profile data 5-9

Progress window

defined 1-3

displaying solution progress 5-7

project

creating 2-1

saving 2-1

validating 5-6, 5-6

Project Manager 2-2

Project Manager window, defined 1-3

project tree, introduction 2-1

Properties window, defined 1-3

R

radiation boundary

assigning 4-2

defined 4-1

reports

animating 6-11, 7-1, 7-1

appearance in the project tree 6-1, 6-3

creating a cloud plot 6-5

creating S11 6-1

creating Z11 6-3

generating 2D graphs 6-1

results

evaluating 6-1

S

S11, creating report of 6-1

simulation, running 5-7

solution

adding a fast frequency sweep 5-3

defining mesh operations 5-5
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results 6-1

viewing convergence data 5-11

viewing matrix data 5-12, 5-14

viewing profile data 5-9

solutions

adaptive 5-1

adaptive analysis 5-7

and setting parameters 5-1

frequency 5-1

setting solution parameters 5-1

status bar, defined 1-3

symmetry boundary

defined 4-1

T

toolbars, defined 1-3

V

validation check 5-6

W

wave ports, impedance multiplier 4-
14

Z

Z11, creating report of 6-3
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